[cfe-commits] r106522 - /cfe/trunk/test/CodeGenObjC/category-class.m

Nico Weber thakis at google.com
Tue Jun 22 01:14:06 CDT 2010


Looks like this didn't help :-/

I just checked again, the test passes for me locally on both 10.5 and
10.6 when synced to ToT. The log even looks like the test passed on
the bot: http://google1.osuosl.org:8011/builders/clang-i686-darwin10/builds/8476/steps/test-clang/logs/category-class.m
– output looks good, $? looks good, but it says FAILED.

Also, the test is set to "XFAIL: * XTARGET: darwin9", and the bot is
darwin10, so the test should be xfail anyway.

Ideas?

On Mon, Jun 21, 2010 at 7:17 PM, Douglas Gregor <dgregor at apple.com> wrote:
> Author: dgregor
> Date: Mon Jun 21 21:17:07 2010
> New Revision: 106522
>
> URL: http://llvm.org/viewvc/llvm-project?rev=106522&view=rev
> Log:
> Attempt to fix test
>
> Modified:
>    cfe/trunk/test/CodeGenObjC/category-class.m
>
> Modified: cfe/trunk/test/CodeGenObjC/category-class.m
> URL: http://llvm.org/viewvc/llvm-project/cfe/trunk/test/CodeGenObjC/category-class.m?rev=106522&r1=106521&r2=106522&view=diff
> ==============================================================================
> --- cfe/trunk/test/CodeGenObjC/category-class.m (original)
> +++ cfe/trunk/test/CodeGenObjC/category-class.m Mon Jun 21 21:17:07 2010
> @@ -1,4 +1,4 @@
> -// RUN: %clang -c %s -o %t && libtool -static -o libcodegentest.a %t && %clang -bundle -o codegentestbundle -L. -lcodegentest -Wl,-ObjC && nm codegentestbundle | grep -F '[A(foo) foo_myStuff]'
> +// RUN: %clang -c %s -o %t.o && libtool -static -o libcodegentest.a %t.o && %clang -bundle -o codegentestbundle -L. -lcodegentest -Wl,-ObjC && nm codegentestbundle | grep -F '[A(foo) foo_myStuff]'
>  // XFAIL: *
>  // XTARGET: darwin9
>  // PR7431
>
>
> _______________________________________________
> cfe-commits mailing list
> cfe-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits
>



More information about the cfe-commits mailing list