[llvm-commits] [llvm] r94974 - in /llvm/trunk/tools/ed: EDDisassembler.cpp EDDisassembler.h EDInst.cpp EDInst.h EDMain.cpp EDOperand.cpp EDOperand.h EDToken.cpp EDToken.h EnhancedDisassembly.exports
scallanan at apple.com
Mon Feb 1 18:24:34 CST 2010
you're right, and I definitely wouldn't name an executable that way.
The library that's built in tools/ed is libEnhancedDisassembler.a/.so. The reason I called the directory ed is that if I called it EnhancedDisassembly it would play havoc with what people see when they type 'ls' in the tools subdirectory, and it would be annoying to cd into that directory.
If you think the potential confusion still outweighs the benefits of a compact folder name, let me know and I'll see what I can do to fix it.
On Feb 1, 2010, at 12:23 PM, Dan Gohman wrote:
> Hi Sean,
> "ed" is the name of a standard utility program in POSIX, SUS, etc.
> On Feb 1, 2010, at 12:49 AM, Sean Callanan wrote:
>> Author: spyffe
>> Date: Mon Feb 1 02:49:35 2010
>> New Revision: 94974
>> URL: http://llvm.org/viewvc/llvm-project?rev=94974&view=rev
>> Added the enhanced disassembly library's implementation and
>> fleshed out the .exports file. I still have to fix several
>> details of operand parsing, but the basic functionality is
>> there and usable.
>> Added: llvm/trunk/tools/ed/EDDisassembler.cpp
More information about the llvm-commits