[LLVMbugs] [Bug 8624] New: Possible llvm problem when ModulePass requires FunctionPasses

bugzilla-daemon at llvm.org bugzilla-daemon at llvm.org
Tue Nov 16 02:10:23 CST 2010


http://llvm.org/bugs/show_bug.cgi?id=8624

           Summary: Possible llvm problem when ModulePass requires
                    FunctionPasses
           Product: new-bugs
           Version: trunk
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P
         Component: new bugs
        AssignedTo: unassignedbugs at nondot.org
        ReportedBy: zhousheng00 at gmail.com
                CC: llvmbugs at cs.uiuc.edu


Created an attachment (id=5786)
 --> (http://llvm.org/bugs/attachment.cgi?id=5786)
Experimental Pass

Consider a case when a module pass requires two function passes fp1, fp2. When
getAnalysis<fp1>() is called, both fp1 and fp2 are executed. That is fine. In
the worst case, we just spend lots of time running the analysis passes many
times.

But it should not crash. In the experimental pass, command "opt" got an
assertion.

The experimental pass is attached. Using the following command:

$ opt -load LLVMTestPass.so  -mpass x.bc -o y.bc

got:

MyFPass running on __cxx_global_var_init
MyFPass2 running on __cxx_global_var_init
opt:
/developer/home2/zsth/projects/llvm.org/llvm/include/llvm/PassAnalysisSupport.h:239:
AnalysisType& llvm::Pass::getAnalysisID(const void*, llvm::Function&) [with
AnalysisType = MyFPass]: Assertion `ResultPass && "Unable to find requested
analysis info"' failed.


Seems the function pass fp1 and fp2 were correctly invoked by the module pass,
but why it dumped the assertion at last.

-- 
Configure bugmail: http://llvm.org/bugs/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the LLVMbugs mailing list